
Seapath® 130 series  

Operator Manual

Compact GNSS aided Inertial Navigation System

IngvildS
KM Document ID





Seapath 130 series
Compact GNSS aided Inertial

Navigation System

Operator manual

M340-53/6.0
June 2024 © Kongsberg Discovery AS

IngvildS
KM Document ID



Document history

Document number: M340-53 / Revision 6.0

Rev. 1.0 December 2016 First version.

Rev. 2.0 May 2017 New names on the product range.

Rev. 3.0 July 2018 Updated to correspond with Product sw version 1.02.00 and support
of Galileo and Beidou satellites.

Rev. 4.0 February 2020 Updated recalibration of MRU chapter.

Rev. 5.0 September 2023 Updated to correspond with Product sw version 2.01.00.

Rev. 6.0 June 2024 Updated roll and pitch specifications. Updated the chapter
“Post-processing of raw data”.

Copyright
©Kongsberg Discovery AS
All rights reserved. No part of this work covered by the copyright hereon may be reproduced or otherwise 
copied without prior permission from Kongsberg Discovery AS.

Note
The information contained in this document remains the sole property of Kongsberg Discovery AS. No 
part of this document may be copied or reproduced in any form or by any means, and the information 
contained within it is not to be communicated to a third party, without the prior written consent of 
Kongsberg Discovery AS.
Kongsberg Discovery AS endeavours to ensure that all information in this document is correct and fairly 
stated, but does not accept liability for any errors or omissions.

Warning
The equipment to which this manual applies must only be used for the purpose for which it was 
designed. Improper use or maintenance may cause damage to the equipment and/or injury to personnel. 
The user must be familiar with the contents of the appropriate manuals before attempting to operate 
or work on the equipment.
Kongsberg Discovery disclaims any responsibility for damage or injury caused by improper installation, 
use or maintenance of the equipment.

Comments
To assist us in making improvements to the product and to this manual, we welcome comments and 
constructive criticism.
e-mail: kd.seatex@kd.kongsberg.com

Kongsberg Discovery AS
www.kongsberg.com



Operator manual

Table of contents

1 ABOUT THIS MANUAL ...................................................... 7
1.1 About this manual...................................................................................................7
2 SEAPATH 130 .................................................................. 8
2.1 Product description.................................................................................................8
2.2 System diagram ......................................................................................................9
2.3 System units..........................................................................................................11

2.3.1 Seapath 130 sensor unit description........................................................... 11
2.3.2 MRU description ..................................................................................... 11
2.3.3 Light weight MRU subsea bottle description.............................................. 11
2.3.4 Spider cable description............................................................................ 12

2.4 Network security ..................................................................................................12
2.5 Support information..............................................................................................13
3 GETTING STARTED ........................................................ 14
3.1 Starting and stopping the Seapath operator software ...........................................14

3.1.1 Starting the Seapath operator software....................................................... 14
3.1.2 Stopping the Seapath operator software ..................................................... 14

3.2 Restarting the Seapath system ..............................................................................14
3.3 Operational principles ..........................................................................................15

3.3.1 Operator software configuration description............................................... 15
3.3.2 Changing the system mode ....................................................................... 15
3.3.3 Browsing or switching display views......................................................... 16

3.4 User preference procedures ..................................................................................17
3.4.1 Selecting colour palette for display............................................................ 17
3.4.2 Selecting presentation format.................................................................... 17
3.4.3 Selecting the default position of views in the display .................................. 17

4 OPERATIONAL PROCEDURES ......................................... 19
4.1 Tuning heave measurement performance.............................................................19
4.2 Acknowledging events .........................................................................................20
4.3 Exporting system data with Data Export tool.......................................................21
4.4 Exporting system data with FTP (File Transfer Protocol) ...................................22
4.5 Post processing of raw data ..................................................................................23

4.5.1 Configuring Seapath for post processing output.......................................... 23
4.5.2 Post processing of raw data in TerraPos ..................................................... 24

5 USER INTERFACE........................................................... 29
5.1 Display organisation .............................................................................................29

5.1.1 Top bar.................................................................................................... 30
5.1.2 DGNSS link status bar ............................................................................. 30
5.1.3 System modes.......................................................................................... 30

M340-53/6.0 3



Seapath 130 series

5.1.4 System status ........................................................................................... 31
5.1.5 Data quality status.................................................................................... 31
5.1.6 Events ..................................................................................................... 32
5.1.7 Application menu..................................................................................... 33

5.2 Display views .......................................................................................................33
5.2.1 Sky view ................................................................................................. 33
5.2.2 DGNSS view........................................................................................... 35
5.2.3 Integrity view .......................................................................................... 36
5.2.4 Compass view ......................................................................................... 38
5.2.5 Motion data view ..................................................................................... 38
5.2.6 Time series view ...................................................................................... 39

5.3 Application menu (Menu system) ........................................................................40
6 MENU SYSTEM ............................................................... 42
6.1 About the menu system ........................................................................................42
6.2 View menu............................................................................................................42

6.2.1 Display mode .......................................................................................... 42
6.2.2 View group.............................................................................................. 43
6.2.3 Display format......................................................................................... 44
6.2.4 Bars group............................................................................................... 45

6.3 Alarm menu ..........................................................................................................45
6.3.1 Expert mode ............................................................................................ 46

6.4 Tools menu ...........................................................................................................47
6.4.1 Utilities group.......................................................................................... 47
6.4.2 Diagnostics group .................................................................................... 47
6.4.3 Log group................................................................................................ 48

6.5 System menu ........................................................................................................48
6.5.1 Configuration group ................................................................................. 49
6.5.2 Information ............................................................................................. 49
6.5.3 System control group ............................................................................... 49

7 MAINTENANCE .............................................................. 51
7.1 Recalibration of the MRU ....................................................................................51
7.2 Updating the sensor unit software ........................................................................51
7.3 Checking the product version ..............................................................................52
7.4 Repairs and parts replacement..............................................................................53

7.4.1 Repairing the sensor unit .......................................................................... 53
7.4.2 Installing a spare sensor unit ..................................................................... 53
7.4.3 Repairing the MRU subsea bottle .............................................................. 53
7.4.4 Installing a spare MRU subsea bottle......................................................... 54

7.5 Troubleshooting....................................................................................................54
7.5.1 System status ........................................................................................... 54
7.5.2 No power ................................................................................................ 54
7.5.3 External output problems.......................................................................... 54

4 M340-53/6.0



Operator manual

7.5.4 All data quality status indicators are grey................................................... 55
7.5.5 All data quality indicators are red.............................................................. 55
7.5.6 Pos/Vel indicator is red............................................................................. 55
7.5.7 Pos/Vel indicator is yellow........................................................................ 56
7.5.8 Heave and Roll/Pitch indicators are red ..................................................... 56
7.5.9 Heave and Roll/Pitch indicators are yellow................................................ 56
7.5.10 Heading indicator is red............................................................................ 57
7.5.11 Heading indicator is yellow ...................................................................... 57
7.5.12 Heave indicator is yellow ......................................................................... 57
7.5.13 Roll/Pitch indicator is yellow.................................................................... 58
7.5.14 No data from the motion reference unit (MRU).......................................... 58
7.5.15 Unstable data from the motion reference unit (MRU) ................................. 58
7.5.16 Echo sounder depth error.......................................................................... 58
7.5.17 Unstable heading calculations for high dynamic vessels ............................. 59
7.5.18 Using GLONASS in RTK solution............................................................ 60
7.5.19 Setting up distribution channel parameters for the sensor unit ..................... 61

8 CONCEPT DESCRIPTION ................................................ 63
8.1 System architecture ..............................................................................................63
8.2 Main data flow......................................................................................................64
8.3 Real-time heave computation ...............................................................................65

8.3.1 Selection of heave filter mode ................................................................... 65
8.4 Delayed heave output ...........................................................................................68
8.5 High speed data in real-time.................................................................................68

M340-53/6.0 5



Seapath 130 series

6 M340-53/6.0



About this manual

1 About this manual

1.1 About this manual
Observe the general information about the Seapath 130 series in this manual. This
manual applies to the Seapath 130–3, 130–5 and 130–5+ products.

Purpose of manual

The purpose of this operator manual is to provide the descriptions and procedures
required to operate the Seapath 130 series of products on a vessel.

Target audience

This operator manual is intended as a reference manual for the personnel operating
the system.

License information

Export of the MRU 5+, MRU 5, MRU H, miniMRU 50 or miniMRU 60 component
requires an export license.

Registered trademarks

Seapath® is a registered trademark of Kongsberg Discovery AS in Norway and the
People’s Republic of China.
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2 Seapath 130

2.1 Product description
The Seapath 130 is developed specifically for hydrographic surveying where
high precision heading, position, roll, pitch, heave and timing are critical
measurements. The product combines state-of-the-art dual frequency GNSS receivers
(GPS/GLO/GAL/BDS), inertial technology and processing algorithms in a compact and
portable package.
The main component is the sensor unit with the motherboard, GNSS antennas and
receivers. The sensor unit is to be mounted on top of the vessel mast or pole. On top of
the transducer, the inertial sensor of type MRU 3, 5 and 5+ is mounted within a light
weight subsea bottle. The Seapath operator software is installed on a connected PC
for configuration and monitoring. All the components are connected through a spider
cable with MRU (Motion Reference Unit) connection, three configurable serial lines,
DGNSS (Differential GNSS) correction input, 1PPS output, network communication
and power inlet.
The latest Seapath software includes Automatic Online Calibration (AOC) that
significantly improves the roll and pitch accuracy. With the AOC functionality
recalibration of the IMU is now longer required if the vessel is in motion with heading
changes (not stationary vessels).
The Seapath 130 series is delivered in the following and improved product range:
• Seapath 130–3 with MRU 3 to 0.010° roll and pitch accuracy
• Seapath 130–5 with MRU 5 to 0.008° roll and pitch accuracy
• Seapath 130–5+ with MRU 5+ to 0.005° roll and pitch accuracy
Note

The MRU 3 model part of Seapath 130–3 has to be mounted in a fixed direction relative
to the vessel and that is with the connector pointing up or down. Else the performance
of the Seapath 130–3 will be degraded.

The advanced Seapath navigation algorithms integrate the RTK GNSS data with
the inertial sensor data. This gives the Seapath 130 unique advantages compared to
stand alone RTK products. The Seapath product’s accurate roll, pitch and heading
measurements allow the RTK antenna position to be referenced to any point on the
vessel where accurate position and velocity are required. All the data from Seapath have
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the same time stamp and the output is in real-time. Subdecimetre position accuracy can
be achieved through download of satellite orbit and clock data from internet and by
post processing of satellite and IMU (Inertial Measurement Unit) data. The Seapath is
robust against GNSS dropouts by using the inertial sensor for dead reckoning navigation
in order to provide position, velocity and also heading measurements when GNSS is
not available.

With latest Seapath software the typical position drift for MRU 3, and MRU 5/5+ after
GNSS droupout is shown in the plot below:

Figure 1 Typical position drift in meters after GNSS dropout in minutes

The product has three configurable RS-232/422 serial lines and Ethernet for output
of motion data and NMEA messages to the multibeam and survey computer. Input
of DGNSS corrections of various quality and sources are input on a configurable
RS-232/422 serial line or Ethernet.

By utilising standard DGNSS, Fugro SeaSTAR XP2/G2/G4/G4+, VERIPOS
Ultra/Ultra2, C-NavC1, C-NavC2 and RTK corrections, this system is a unique solution
for hydrographic surveying and dredging work which demand the most comprehensive,
most accurate surveying data available.

2.2 System diagram
A system diagram for a Seapath setup.
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Main units
1 Sensor unit with 1 meter cable with male connector
2 Mounting bracket
3 Seapath operator software installed on a PC (not part of the delivery)
4 Motion reference unit (MRU) in subsea bottle

Cables
A Cable to the sensor unit, part of the spider cable, 20 meter length with female

connector
B MRU umbilical cable with 8–pin SeaCon connector, 15 meter length
C Ethernet cable to PC and other users, 5 meter length
D Input/output serial line for GNSS corrections with 9–pin Dsub, 5 meter length
E Output serial line for motion data to multibeam or survey computer with 9–pin

Dsub, 5 meter length
F Output serial line for NMEA data with 9–pin Dsub, 5 meter length
G 1PPS output with 9–pin Dsub, 5 meter length
H 24 VDC input, 5 meter length
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2.3 System units
The Seapath product comprises the following main components.

2.3.1 Seapath 130 sensor unit description
The sensor unit runs the navigation software. This software combines the GNSS signal 
and the inertial measurements to determine accurate position, heading, attitude and 
heave signal. This software utilises Kongsberg Discovery AS advanced true multi-
reference algorithms for real-time parallel processing of all available correction signals.

The sensor unit includes:
• Two GNSS receivers

and antennas
• Motherboard
• Connector board for termination of the spider cable
• Cable of 1 meter with male connector
• Mounting bracket

2.3.2 MRU description
The MRU (Motion Reference Unit) is designed for motion
measurement in marine applications. The unit incorporates 3-axis
sensors for linear acceleration and angular rate, along with complete
signal processing electronics and power supply. The MRU outputs
absolute roll and pitch as well as dynamic acceleration in the north,
east and down direction, velocity and relative position.

The interior of the MRU is divided into two sub-assemblies
consisting of an electronic part and a sensor part. The sensor unit
shall not be repaired or serviced by anyone else than Kongsberg
Discovery AS.

2.3.3 Light weight MRU subsea bottle description
The MRU is mounted in a light weight subsea bottle. The top and bottom
cover plates of the bottle are made of PVC and the cylinder of aluminum.
The bottle is designed for use down to 10 metres. The MRU is mounted
on a steering plate inside the bottle.

On the outside there are four mounting holes (M6) on both cover plates.
The mounting direction of the MRU within the bottle is indicated on the
bottom cover plate.

The bottle is delivered with two 8-pin Seacon connectors, one for serial
and one for Ethernet communication.
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2.3.4 Spider cable description
The product is delivered with a spider
cable for sensor unit connection
through the female connector, MRU
connection through the 8–pin SeaCon
connector, three configurable serial
lines through 9–pin Dsubs, 1PPS
output through 9–pin Dsub, network
communication and power inlet.
Delivered in either 20 meter length or 8 meter length (short).

2.4 Network security
Equipment manufactured by Kongsberg Discovery AS is frequently connected to local
area networks (LAN). Connecting any computer to a network will always expose the
data on that computer to all other computers connected to the same network. Several
threats may immediately occur:
• Remote computers can read the data.
• Remote computers can change the data.
• Remote computers can change the behaviour of the computer, for example by

installing unwanted software.

Usually, two parameters are used to define the threat level:
1 The likelihood that any remote connection will do any of the above.
2 The damage done if a remote connection succeeds doing this.

Because Kongsberg Discovery AS has no information regarding the complete system
installation at a location, we can not estimate the threat level and the need for network
security. For this reason, we can not accept responsibility for network security. Systems
provided by Kongsberg Discovery AS are regarded as stand-alone offline systems, even
though they may be connected to a network for sensor interfaces and/or data distribution.

Note

No network safety applications are installed on any Kongsberg Discovery computers.
The computers are thus not protected against viruses, malware or unintentional access
from external users.

Securing the system itself has no meaning unless there is a policy in place that secures all
computers in the network. This policy must include physical access by trained and trusted
users. The customer/end user of the system will always be in charge of defining and
implementing a security policy, and providing the relevant network security applications.
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Note

Kongsberg Discovery AS will not accept any responsibility for errors and/or damages
caused by unauthorized use or access to the product.

2.5 Support information
• Company name: Kongsberg Discovery AS, Seatex
• Address: Havnegata 9, 7010 Trondheim, Norway
• Duty phone: +47 33 03 24 07 (24 hours)
• Support e-mail address: support.seatex@kd.kongsberg.com
• Website: http://www.kongsberg.com/discovery

KM-Support App

Support is also available from the KM Support App. This app is available for free in App
Store and Google Play.
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3 Getting started

3.1 Starting and stopping the Seapath
operator software

3.1.1 Starting the Seapath operator software
Start the Seapath operator software to be able to operate the Seapath
system. There are two ways to start the operator software.

Procedure
1 Double-click the Seapath HMI icon on the desktop to start the

software.
2 Select the Windows Start button and type Seapath in the search box. Select Seapath

Operator SW.

3.1.2 Stopping the Seapath operator software
You can stop the Seapath application on your PC.

Note

The system will still calculate and output data if you stop the operator software.

Procedure
1 Select the System menu→Stop →Operator SW

The message This will end the
application. Are you sure? appears.

2 Select Yes to confirm.

3.2 Restarting the Seapath system
You may need to restart the Seapath system, for example for configuration changes
to take effect.
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Procedure
1 Select the System menu →Restart →Sensor unit

The message This will reboot the sensor unit. Are you sure?
appears.

2 Select Yes to confirm.

3.3 Operational principles
The system starts automatically after power on and is operated through the Seapath
operator software application installed on an external PC.
The Seapath application has a graphical user interface. Use a mouse and keyboard to
operate the application from the application menus and to navigate and select in the
menus. Some commands may also be executed by use of key combinations.

3.3.1 Operator software configuration description
You can adjust the appearance of the display views through the Operator software
configuration dialog box.
The dialog box contains tab pages for various presentation options and each page
contains two confirmation buttons with different properties and a cancel button.
• OK button: selecting the OK button will save the changes and close the Operator

software configuration dialog box.
• Apply button: selecting the Apply button will save the changes but the Operator

software configuration dialog box will not close.
• Cancel button: selecting the Cancel button will close the dialog box and changes

will not be saved.
Note

The position properties selected in the Operator software configuration dialog box are
only for display purposes.

3.3.2 Changing the system mode
The system has three modes: Operation, Configuration, Engineering. To be able to make
changes to the setup you must be in Configuration or Engineering mode. You need a
password to enter these modes. The password is STX and it is not case sensitive. The
password is not possible to change.

Via the System menu

Procedure
1 Select the System menu →Change system mode.
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2 Select either Configuration or Engineering to open the Change system mode dialog
box.

3 Type the password STX and select OK. The password is not case sensitive.
You are now able to carry out changes and/or set system parameters.

With keyboard commands directly from the display

Procedure
1 In the display, press

• CTRL+E to enter Configuration mode
• CTRL+A to enter Engineering mode
Observe that the Change system mode dialog box appears.

2 Type the password STX and select OK. The password is not case sensitive.
You are now able to carry out changes and/or set system parameters.

3.3.3 Browsing or switching display views
The display is divided into three view sections: View 1, View 2 and View 3. You can
select which view you want to appear in these sections.

A Top bar
B View 1
C View 2
D View 3

Menu selection

In the View menu, select the browse or toggle option.

Keyboard commands

Press the F2 key to browse to the next available view
in View 2.

Press the F3 key to switch the contents of View 1 and View 2.
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3.4 User preference procedures

3.4.1 Selecting colour palette for display
You can adjust the brightness and the colours of the display to suit you current light
conditions.

Menu selection

In the View menu, select the display mode which best
suits your current operation:

• Day white: this is the recommended colour palette
for daylight use.

• Day black: this palette has dark background and
bright colours.

• Night: special colour palette for night operations which will not weaken the night
sight of the system operator.

Keyboard commands

You can press the F7 key to toggle between the day palettes and the F8 key to switch
to the night palette.

3.4.2 Selecting presentation format
You can select which formats to use for the presentation
of various data in the display.

In the View menu, select the display format you want to
set and select your preferred options from the submenu.

The display formats you can modify.
• Date format
• Time format
• Position format
• Datum
• Unit system

Related topics
• View menu on page 42

3.4.3 Selecting the default position of views in the display
You can select a default appearance of the views in the display so they will appear in the
same position each time you start the application.

M340-53/6.0 17
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Procedure
1 Select the System menu,

→Operator SW to open the
Operator software configuration
dialog box.

2 Select the View tab.
3 Select which view you want for

View 1, View 2 and View 3 from
the drop-down lists.

4 Select Apply to store the settings.

Related topics
• System menu on page 48
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4 Operational procedures

The sensor unit starts automatically after power on and it is operated through the operator
software installed on an external PC. The operator software is used for performance
monitoring, configuration and system troubleshooting.

Normally, the sensor unit outputs signals on the serial lines and Ethernet ports without
any involvement from the user. After power on, it takes up to 30 minutes before full
accuracy on all data is obtained. Since there normally is no reason to turn off the sensor
unit, it should be left running continuously.

4.1 Tuning heave measurement
performance

Before a survey and/or during operation, check the Seapath heave performance and tune
the heave parameters until the best heave performance is achieved.

Context

When using the Seapath for real-time heave measurements, it is important to tune
the heave period to the vessel size and motion characteristics for the actual weather
conditions. The configuration parameter Heave filter mode defines default values of the
heave period. In order to achieve optimum heave performance, these values have to be
tuned for the actual vessel and weather conditions.

The simplest option is to select Automatic or GNSS aided heave filter mode in NAV Engine
configuration and let the system estimate the heave filter parameters during operation.

Or you can manually tune the heave measurement performance by checking the heave
period parameter in the Data Viewer and then enter this value in the NAV Engine
configuration.

Procedure
1 Select the Tools menu→Data Viewer to open the Data Viewer tool .
2 Under Integrated, select Heave.
3 Observe the Heave period [s] parameter and close the Data Viewer.

M340-53/6.0 19
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4 Select the System menu, →NAVEngine →Standard to open the NAV Engine
Configuration dialog box.

5 Select the MRU node →Heave config.
6 Select Hydrographic survey or General purpose from the Options list.
7 Type the Period parameter you observed in the Data Viewer. Allowed value between

1 and 25 seconds. Default value is 10 seconds.

8 Or you can select Automatic or GNSS aided for the system to estimate the heave
filter parameters.

9 Select the Roll/Pitch dependent box if you want the heave measurement dependent
on the roll and pitch measurements.

10 Select Apply to store the settings.
Note

If you decide to let the system automatically estimate the heave filter parameters,
by selecting Automatic or GNSS aided, you do not need to observe the heave period
parameter in the Data Viewer.

4.2 Acknowledging events
The Top bar will show if the system has one or more event situations. These can range
from informational messages to warnings and alerts. If a situation has been handled
and there is no need for it to be displayed, it can be acknowledged and thus removed
from the Top bar.

Procedure
1 Observe the alarm(s) in the Top bar.
2 Select the Event severity symbol, letter A, W or I, for the event to acknowledge

the event directly.
Observe that the event disappears form the Top bar.
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3 Or you can select the Even list button to open the Event list and view all events.
4 Select the Event severity symbol in the list to acknowledge an event.
5 Or you can select the Alarm menu→Ackn. all events to acknowledge all events.

Observe that there are no events in the Top bar.

Related topics
• Alarm menu on page 45
• Events on page 32

4.3 Exporting system data with Data
Export tool

Use the Data Export tool to copy log data to a USB flash drive, either for documentation,
post-processing or diagnostics purposes.

Procedure
1 Insert a USB flash drive into the external computer with the Seapath operator

software.
If you do not insert a USB flash drive, the files will be written to local disk.

2 Select Tools →Data Export.

3 Select the start time for the data export from the calendar.
4 Select the duration of the exporting period.
5 Select Customize if you want to change which data files you want to export.
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Select which data you want to export and if you want to split the output file into
smaller files.

6 Select Export to start exporting data.
A progress bar will appear on the screen.

7 Exit the Data Export tool when the logging session is finished.

Result

The files are zipped and placed on the USB flash drive inside a folder named
DataExport.

4.4 Exporting system data with FTP (File
Transfer Protocol)

The Seapath system contains an FTP server which can be used to export files to your
computer.

FTP client software must be installed on your computer. For installation, see
documentation for the chosen FTP client.

The directory structure on the FTP server:
/data/user/loghost

Data from telegram outputs where Log to file has been selected in the NAV Engine
Configuration →Communication interface →Input/Output. The file name extensions
are .lnn (lowercase L, not one), where nn is the two-digit output number.

/data/user/other
Other directories are used for diagnostic and maintenance purposes. Instructions
are given from customer support if these types of files are needed.
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Prerequisite
You must be familiar with the sensor unit’s internet protocol (IP) address to be able to
connect to it.
The default IP address for the sensor unit is: 192.168.1.10.

Procedure
1 Start the FTP client software on your computer and connect to the sensor unit IP

address.
2 Log in by typing the user name and password.

• User name: navigator
• Password: navigator
The user name and password are case sensitive.

3 Select Binary or Text transfer mode depending on how the data shall be used.
Binary transfer mode is usually the correct choice for machine-readable data.

4 Transfer the wanted files.
5 Disconnect.

4.5 Post processing of raw data
Seapath can output raw GNSS and IMU data for post-processing with Field Geospatial’s
TerraPos.
It is recommended to log the data on Kongsberg Discovery K-Controller system or on
another connected logging system. Alternatively, the data can be logged internally in
the Seapath system. If logged internally on Seapath, use FTP to download files from
the Seapath disk. Login with user name "navigator", password "navigator" and binary
transfer mode. The files are found on the user/loghost directory. Use the Ethernet port
in the front of the Processing Unit (192.168.1.4). The file extension on the Seapath log
files and enabling logging are as follows:
• The TelegramOut15 interface number is used to log raw GNSS and IMU data to file

by the format Post-processing 1. The raw data log file will get the file extentionbe
*.15.

Note

Make sure to retrieve the data logged internally on the sensor unit periodically if you
need it. When the internal disk reaches 80 % of capacity, it will delete the oldest 120
minutes of logged data. The more logging you enable, the faster the disk will fill up.

4.5.1 Configuring Seapath for post processing output
The outputs must be set up and connected to the optional external logging system before
data collection starts.
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This procedure describes how to set Telegram output interface and, under the Telegram
out properties, how to set up one output with the following format:
• Post-processing 1 (include both raw IMU and GNSS data).
Select Log to file on the output if the data shall be logged internally in the Seapath system.
A possible selection is indicated in the procedure.

Procedure
1 Select the System menu, →NAVEngine →Standard.
2 Select the Communication interface node→Input/Output.
3 Select the TelegramOut15 interface in the Input/Output list.

Observe that the configuration details for Telegram out properties appear at the
lower part of the page.

4 Select Type for output of data on Serial line, Ethernet or None.
5 As Format, select Post-processing 1.
6 Select Log to file if you want data logged internally.
7 Select Apply to store the settings.

4.5.2 Post processing of raw data in TerraPos
After you have logged the raw dat< you can process these data using TerraPos position
and attitude post-processing software.

Prerequisites
Contact Kongsberg Discovery AS by email: seatex.sales@kd.kongsberg.com and
request the TerraPos software and license.

Context
The TerraPos software integrates satellite positioning and inertial sensors for a full six
degrees of freedom solution. It uses Precise Point Positioning (PPP) technology to
provide true autonomy: anywhere, anytime - without worrying about base stations or
reference networks.
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Post-Processed Kinematics (PPK) is also available through selection of a value for Base
station service (CORS). Alternatively, the base station files can be added manually by
adding a DGNSS setup file. The DGNSS setup is created by selecting the Tools menu,
→Edit DGNSS setup.

Note

In the procedure below, you only install the TerraPos software once. If TerraPOs is
already installed and the softkey updated, you go to Processing data.

Procedure
1 Installing TerraPos software:

• Request the TerraPos software
• Install the software using the standard options
• Open the TerraPos application and select Tools →License Tool →Copy fingerprint.

• Send the fingerprint to the Kongsberg Discovery AS sales office. You will now
receive a file by mail.

• Select Tools →License Tool →Update softkey.
2 Processing data:

• Select Workflow →Seapath →Seapath INS.
• SelectWorkflow directory for where to store the files associated with thee

project. You can let the system create a directory by selecting Create and use
temporary working directory or you can select which directory you want to
use by selecting Set working directory manually.
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• Select if you want to Apply new input or if you want to Keep old input.
• Select OK.
• Type a TerraPos project name.
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• In Seapath raw data directory, select the directory where you have stored the
Seapath raw data on format Post-processing 1.

• Select data format, Export format.
• Select datum,Transformation. If you do not select anything here, the default

datum is ITRF.
• Select Run to run the worrkflow.
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5 User interface

5.1 Display organisation
Typical Seapath display.

A Top bar (with Application menu)
B Position data
C View 1
D DGNSS link status bar

E View 3
F View 2
G Application menu

M340-53/6.0 29



Seapath 130 series

5.1.1 Top bar
The Top bar holds system and system status information as well as the Application menu
with the various menus in the system.

A Type of system
B Current date and time
C Data quality status
D Event severity symbol
E Event time tag
F Event source

G Event message
H Number of unacknowledged events
I Application menu
J Event list button
K System status
L System mode (indicated only in

Engineering or Configuration mode)

5.1.2 DGNSS link status bar
The DGNSS link status bar holds status information regarding GNSS differential
correction data links.

The colour of the symbol indicates the status of the link.
• Grey: link not enabled.
• Yellow: data received but not used.
• Green: data are available and OK.
• Red: no data available.
Select the link symbol to open the DGNSS Monitor tool for more detailed information
about the link status.

Related topics
• Tools menu on page 47
• View menu on page 42

5.1.3 System modes
There are three system modes, indicated in the System mode area of the Top bar:
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Operation mode This is the default mode. In this mode it is not possible
to start any external applications, diagnostic tools or
re-configure the system. A password is not required to
switch to this mode.

Configuration mode In this mode it is possible to change settings related to
the connected sensors, applications and system-wide
settings.

Engineering mode This mode is primarily intended for field engineers during
initial installation, fault diagnostics and system-wide
re-configuration.

A password is required to switch from Operation to Engineering or Configuration mode.
The password is stx and it is not possible to change. The password in not case sensitive.
The system will return to Operation mode after 30 minutes of user inactivity.

5.1.4 System status
There are three system states. The system status describes the position integrity level,
and is indicated in the Status field of the Top bar. The background colour of this field
helps indicate the system status. The system states are:

A Safe
B Caution
C Unsafe

• Safe: System integrity OK.
• Caution: Reduced system integrity.
• Unsafe: Low system integrity.

Relate topics
• Integrity view on page 36

5.1.5 Data quality status
The system has four data quality status indicators which
indicate the status of the system measurements.
• Horizontal position and velocity
• Heave
• Roll and pitch
• Heading
The colour codes represent:
• Green: normal operation, input data has good quality.
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• Yellow: reduced performance, input data has reduced quality.
• Red: invalid data or no input data.

The quality status information output on serial lines or Ethernet is the same as indicated
on the data quality status indicators.

5.1.6 Events
Events which appear in the Seapath application can be set up with different alarm types.
These alarm types have different severity levels.

• Alarm: alarms – high priority

• Warning: warnings – medium priority

• Info: information messages – low priority

An event message is acknowledged by selecting the Event severity symbol, letter A,W
or I, in the Top bar. When an event is acknowledged, it disappears from the Event list.
However, the event can still be viewed in the alarm status under the Alarm menu.

A Event severity symbol
B Event time tag
C Event source

D Event message
E Event list button
F Number of unacknowledged events

Select the Even list button to open the Event list where you can see all the
unacknowledged events. Select the button again to close the list.
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5.1.7 Application menu
The four menu buttons located to the far right on
the Top bar constitute the Application menu. Select
a button to open the menu to reveal a drop-down list
of sub-menus. These menus offer various operational
and visual options.
• View: selections for colour palette, switching between views, display format

presentation and display of DGNSS link status bar and/or position data in main view.
• Alarm: acknowledge alarms, view status of active alarms.
• Tools: selection of operational tools and tools to use for various diagnostic purposes.
• System: system configuration, system mode change, system version, system stop

and log off.

5.2 Display views

5.2.1 Sky view
The Sky view display shows which satellites the system is tracking and using in the
position computation. The satellites are presented according to satellite geometry. The
grey outer circle represents the elevation mask. The satellite azimuth angle is according
to the north-south axis.

M340-53/6.0 33



Seapath 130 series

A Number of used GPS satellites
B Number of tracked GPS satellites
C Number of used GLONASS satellites
D Number of tracked GLONASS

satellies
E Current HDOP value
F Vessel heading
G GPS satellite
H GLONASS satellite

I Correction satellite
J Shadow sector
K Satellite under shadow sector
L Satellite under elevation mask
M Elevation mask
N Signal-to-noise ratio indicator
O Track plot

The number of GPS and/or GLONASS satellites tracked and used in the position
solution, is presented in the upper left and right corners of the display.
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The satellite colours represent type of satellite and condition of satellite.

A GPS satellite
B GLONASS satellite
C SBAS satellite

D Disabled satellite
E Rejected satellite
F Correction satellite

The satellites with grey colour are disabled as they are not used directly in the position
fix. Satellites with red colour are faulty and not used in the position fix.
The bar(s) at the bottom of each satellite represent(s) the
signal-to-noise level for the satellite, and the longer the bar, the
stronger the signal.
The upper bar indicates the signal strength for GNSS receiver
1, the lower for GNSS receiver 2.
When the cursor hovers over a satellite symbol, a tooltip will
appear with the status of the satellite including azimuth, elevation,
L1/L2 signal-to-noise ratio and differential correction availability.
If the vessel has a gyro interfaced, the display shows the vessel's
true heading.
The shadow sector represents areas with obstructions. You can add shadow sectors.
Adding shadow sectors will have no effect on calculations but will assist in explaining
why some satellites are not used in the position fix.
The HDOP (Horizontal dilution of precision) is a measure of the geometric quality
of a GPS satellite configuration in the sky. The smaller the DOP number, the better
the geometry.
You can select the appearance of the Sky view from the System menu→Operator SW
→Sky view tab. Here you can enable or disable the correction satellites, the signal
strength bars, the track plot length, shadow sectors and the elevation mask.

Related topics
• For more details on the Sky view, refer to the Installation manual.

5.2.2 DGNSS view
There DGNSS view indicates the status of the available correction links.
The link status for all links is indicated with a colour:
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• Green: correction data are received and used in the position solution.
• Yellow: data are received but not used.
• Red: no data are received through that link.
• Grey: the link has been disabled for some reason.
Status of up to 9 correction links can be displayed. Each link is identified by a name
which is defined in the NAV Engine Configuration dialog box, Communication interface
node→Input/Output. The number of reference stations used in the position calculation
and the number of reference stations available, are indicated for each correction link.

A Name of correction link
B Number of available reference stations
C Number of reference stations used in

the position solution
D Age of correction data
The DGNSS view presents each link as
a circular button and presents a bar that
indicates the quality as the age of the
corrections received through that link. If
a bar is filled green, the correction signals
are newer. The older the signals are, the
shorter the bar is.
If the bar is grey, the age of the corrections
has exceeded the maximum age, and the
corrections from the link are not in use.
If you select one of the link buttons, the DGNSS Monitor appears. This view lists details
of all available reference stations from all correction links.
Select the System menu→NAV Engine →Standard to enter the NAV Engine Configuration
dialog box. You will find the DGNSS configuration details under the Communication
interface node →Input/Output.

Related topics
• For more details on the DGNSS view, refer to the Installation manual
• Tools menu on page 47

5.2.3 Integrity view
The Integrity view indicates the position integrity of the system position according to the
IMO requirements to positioning equipment based on the RAIM exclusion and detection
algorithm implemented. The integrity indication for different position accuracy levels
is expressed in three states (Safe, Caution and Unsafe) according to the requirements.
The different states are indicated with colours (green, yellow and red) on the vertical
bar in the view.
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The error ellipse describes the position quality and the geometry of the position solution.
The position accuracy level is configurable from the setup file (the value is displayed as
the outer circle on the axis). Default value is 10 m.
The system integrity value is often referred to as the horizontal external reliability. It
gives an indication of how large a horizontal position error might be, at the condition of
an arbitrary undetected satellite failure.
• Safe (green) indicates that the system accuracy is below the selected accuracy level

and that a single satellite failure cannot make the actual horizontal position error
exceed the selected integrity limit (95 % confidence level).

• Caution (yellow) indicates that the system accuracy is below the selected position
accuracy level but a single satellite failure might not be detected. If such a satellite
failure is detected, the actual horizontal position error might exceed the selected
integrity limit (95 % confidence level). With only four satellites (three when height
aiding is chosen), there is no way to detect a satellite failure, and the system will
always be in the state Caution or Unsafe. The expected accuracy and HDOP might
still be reasonably low.

• Unsafe (red) indicates that the system accuracy is above the selected accuracy level
(95 % confidence level)

A Diagram resolution scale, configurable
B Error ellipse
C Integrity indication bar value
D Default position accuracy value, 10 m
E Integrity indication bar
F Current EPE (Estimated Position Error)
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G Graphical presentation of EPE over the last 240 seconds

Related topics
• For more details on the Integrity view, refer to the Installation manual.

5.2.4 Compass view
The Compass view shows the vessel heading, course over ground (COG) and speed over
ground (SOG). The arrow heads indicate the speed according to the speed scale.

A Speed scale
B Vessel heading and (HDG) and speed along ship (SL)
C Vessel speed over ground (SOG) and course over ground (COG)

Related topics
• For more details on the Compass view, refer to the Installation manual.

5.2.5 Motion data view
The main function of the Motion data view is to give information about the speed and
heading of the vessel.

Longitudinal and transversal speed (SL and ST) are presented together with arrows
indicating forward/aft and port/starboard directions. The arrows and the vessel's course
over ground (COG) are not displayed if the speed over ground (SOG) is less than 0.1 m/s.

Also the vessel roll, pitch, heave and rate of turn (ROT) are shown in this view.
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A Vessel speed along ship (SL)
B Vessel speed transverse ship (ST)
C Vessel roll
D Vessel heave

E Vessel heading (HDG)
F Vessel pitch
G Vessel rate of turn (ROT)
H Vessel speed over ground (SOG)
I Vessel course over ground (COG)

5.2.6 Time series view
This view plots roll, pitch, heave and heading as time series. The colour of the time
series graph indicates the data quality.
• Red: invalid data.
• Yellow: reduced accuracy.
• Green: normal performance.

In the heave time series both real-time heave and delayed heave are presented in the same
time series. Therefore the heave time series is always 2 minutes delayed in time in order
to be able to present both measurements in the same curve and for the same sample.

You can zoom in parts of each plot and pan the time series by dragging the active
controls. You can lock the time axis for the time series you want to take a closer look at
by selecting the padlock symbol.
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A Roll in degrees
B Pitch in degrees
C Heave in metres
D Heading in degrees

E Lock/unlock time axis
F Time axis
G Y axis 0
H Y axis scale, max.

5.3 Application menu (Menu system)
Access to the menu system is in the Application menu
part of the Top bar.

Select the menu buttons to reveal the menu items and
select the menu items to reveal the sub-menus.
View menu

The View menu holds user preference selections for which colour palette to use for
the current light conditions. Here you can maximize the main view and switch and
toggle between the various display views. You can select which format to use for
presentation of data in the display, such as date and time format, position format,
unit measurement system. Position data can be displayed at the top of View 1 and
DGNSS link status can be displayed at the bottom of View 1.

Alarm menu
The Alarm menu allows you to acknowledge alarms, or events, which have
occurred in the system. You can also see status details for the alarms which are
active. The NAV Engine debug option is for advanced users and shows output of
status messages for NAV Engine and is used for troubleshooting purposes.
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Tools menu
The Tools menu holds various tools used for planning and operation and tools used
for diagnostic purposes. Which tools are available will differ according to type
of product purchased.

System menu
The System menu holds the NAV Engine configuration and the operator software
configuration. This is where you change the system mode or performs a restart,
stop or shutdown of the system. This is also where you find various information
about the system, such as contact details, software version and equipment
information. This menu holds a quick help with shortcut keys for switching display
views and changing the colour palette.
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6 Menu system

6.1 About the menu system
Access to the menu system is in the Application menu
part of the Top bar.
Select the menu buttons to reveal the menu items and
select the menu items to reveal the sub-menus.

6.2 View menu
The View menu is located in the Application menu
part of the Top bar. It is divided into four groups which
provide selections for colour palette, switching between
views, display format presentation and display of
DGNSS link status bar and/or position data in View 1.

How to open
Select View in the Application menu on the Top bar.

6.2.1 Display mode
Display mode controls the selection of colours used by
the HMI. Select the menu item which corresponds to
the desired mode or colour palette.

Details
Day white

This is the recommended colour combination for daylight use.
Day black

This colour combination uses bright colours, but has a dark background.
Night

This is a special palette with very low contrast on black background, intended to be
used during night without weakening the night sight of the operator.
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You can press the F7 key to toggle between the day palettes and the F8 key to switch
to the night palette.

6.2.2 View group
The display is divided into three view sections: View 1, View 2 and View 3. View allows
you to decide which view you want to appear in these sections.

Details
Maximise main view

Select to let View 1 cover the whole screen. This has the same effect as pressing
the F5 key.

Browse top views
Select to browse to the next available view in View 2. This has the same effect
as pressing the F2 key.

Browse bottom views
Select to browse to the next available view in View 3. This has the same effect
as pressing the Shift + F2 key.

Toggle top view
Select to switch the contents of View 1 and View 2. This has the same effect
as pressing the F3 key.

Toggle bottom view
Select to switch the contents of View 1 and View 3. This has the same effect
as pressing the Shift + F3 key.

Note

Browsing or switching views using F2 and F3 is not stored. The only way to ensure that
the selected contents is displayed every time the software starts, is to make the selection
in the View tab in the Operator software configuration dialog box.

Figure 2 Browse with F2 key
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Figure 3 Switch with F3 key

Related topics
• Browsing or switching display views on page 16
• Selecting the default position of views in the display on page 17

6.2.3 Display format
Display format provides alternatives to modify the presentation of various data types.
When selecting a view menu item of this group, or hovering the mouse cursor over it, a
sub-menu will appear to the left, containing option items for selecting the wanted format.

Details
Date format

Select between various date formats. The selected format is used in displayed
fields presenting date information, e.g. the date part of the Top bar.

Time format
Select between AM/PM and 24-hour display of time values. Influences all
displayed fields presenting time information, for example current date and time
and event fields of the Top bar.

Position format
Select between decimal seconds (e.g. N 63°26'31.92''), decimal minutes (e.g. N
63°26.5320') and UTM. All positions displayed in the various views and dialog
boxes will follow this selection.

Datum
Select the datum in which positions are presented. Be aware that this selection is
only valid if the datum on the corrections input to the product is in WGS84 or if no
corrections are input. If the corrections input are in another datum than WGS84,
you must selectWGS84. See the Installation Manual for available selections.

Unit system
Select the length and speed units used in the various views. Two types of unit
system selections are available: Fixed units and Auto-scaling units. Each
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alternative indicates the distance unit, then the speed unit. Auto-scaling units will
change from short range unit to long range unit (indicated in parenthesis) when the
number of digits in the displayed value exceeds a certain limit.
Available fixed units:
• NM, knots
• m, m/s
• ft, ft/s
Available auto-scaling units:
• M (km), km/h
• m (NM), knots
• ft (NM), knots

Related topics
• Selecting presentation format on page 17

6.2.4 Bars group
The Bars group allows you to decide whether the DGNSS link status bar shall appear
at the bottom of View 1 or not or if the vessel position and datum shall appear at the
top of View 1 or not.

Details
DGNSS links

Displays the DGNSS Link status bar at the bottom of View 1 when selected.
Position data

Displays the vessel position and datum at the top of View 1 when selected.

6.3 Alarm menu
The Alarm menu is located in the Application
menu part of the Top bar. The menu allows you to
acknowledge alarms, or events, which have occurred
in the system. You can also see status details for
the alarms which are active.

How to open
Select Alarm in the Application menu on the Top bar.

Details
Acknowledge alarm

Select this menu item to acknowledge the topmost event viewed in the Top bar.
You can also press the F10 or select the Event severity symbol in the Top bar.
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The Acknowledge alarm option is disabled if no alarms are available in the Event
list in the Top bar. Acknowledged alarms are still available in the alarm log, but
removed from the Top bar view.

Ackn. all alarms
Select this menu item to acknowledge all the events viewed in the Event list in
the Top bar at once. You can also press Ctrl+F10. The Ackn.all alarms option is
disabled if no alarms are available in the Top bar.

Status
Select this menu item to open the Alarm status dialog box. You can also press
Ctrl+H. This dialog box allows you to see all the active alarms. Use the radio
buttons to filter the alarms according to alarm severity. You can also acknowledge
the selected alarm or all alarms. When an alarm message is acknowledged, but
still active, the alarm message text will be grey. The alarm message will only be
removed from the list when it becomes inactive.

Related topics
• Events on page 32
• Acknowledging events on page 20

6.3.1 Expert mode
Expert mode contains parameters which can be used for troubleshooting and they are
for advanced users only.

Details
NAV Engine debug

Output of status messages for NAV Engine. For advanced users and
troubleshooting purposes.
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6.4 Tools menu
The Tools menu is located in the Application
menu part of the Top bar. It is divided into three
groups which provide applications for planning
an operation, configuration tasks and various
diagnostic and logging purposes.

How to open
Select the Tools button in the Application menu
on the Top bar.

6.4.1 Utilities group
The Utilites group holds applications for export
of system data and copying and restoring the
system configuration.

Details
Data Export

Data Export is a tool which copies log data to a USB flash drive, either for
documentation, post-processing or diagnostics purposes. You can select the start
time and the duration of the data export.

Copy Configuration
The Copy Configuration tool copies the complete system configuration to a disk
based archive file or to a USB flash drive. You can use the USB flash drive with
the copied configuration to restore the system configuration at a later date. The use
of this application is described in detail in the Installation Manual.

Restore Configuration
The Restore Configuration tool restores all relevant configurations from a disk
based archive file or from a USB flash drive. The use of this application is
described in detail in the Installation Manual.
Note

A configuration archive can only be restored from the same type of unit (Remote
HMI or Processing Unit) on which it was created.

6.4.2 Diagnostics group
The Diagnostics group holds applications for advanced users for diagnostic purposes
only.

Details
DGNSS Monitor

The DGNSS Monitor tool shows information about available reference stations.
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Data Viewer
The Data Viewer tool shows raw data information about the satellites which are
tracked by the receiver, position fix information, correction data and Processing
Unit status. You can use this tool for system verification and diagnostics.

Port Monitor
The Port Monitor tool shows the data traffic on all serial and net ports.

Explorer
The Explorer menu item opens Windows Explorer where you can view the file
system of the HMI Unit.

Windows shell
The Windows shell menu item opens a Windows command shell.

6.4.3 Log group
The Log group is for advanced users for diagnostic purposes only.

Details
Screen dump

The Screen dump tool creates screen dumps of the operator software. You can
store the screen dump image on the local disk or on a USB flash drive.

NAV Engine Log
Opens the Windows Explorer in the root folder for the NAV Engine log data.
If the NAV Engine software is not running on the same unit as the operator
software, an FTP session is opened on the Processing Unit to which the operator
software is connected rather than a session on the local file system.
Note

It is recommended to use the Data Export tool rather than NAV Engine Log.

6.5 System menu
The System menu is located in the Application menu
part of the Top bar. It is divided into three groups
which allow you to configure the system, specify the
contents of the views, change the system modes, stop
and log off the system in a controlled way.
Some menu items may be disabled depending on
the system mode selection. Disabled menu items
appear with light grey text. Change system mode to
Configuration or Engineering to activate the disabled
menu items.
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How to open
Select the System button in the Application menu on the Top bar.

6.5.1 Configuration group
The Configuration group allows you to enter the system setup parameters and to enter
the display setup settings.

Details
System configuration

Opens the System configuration dialog box from which you can set up your system
to be ready for operation.

Operator SW
Opens the Operator software configuration dialog box with the tab pages where you
can set up visual parameters for the display views.

6.5.2 Information
Information contains quick help and product version information.

Details
Help

Displays the Quick Help information sheet with basic information regarding
navigation and selection.

About
Displays the About dialog box which contains various information about the
system, such as contact details and software version. Select Details to see more
equipment information.

6.5.3 System control group
The System control group allows you to change the mode in which the system shall
operate, to stop and restart the GUI, to shutdown and restart the unit and to log off
the system in a controlled way.
Change system mode

Changes the system's operating mode. Switching to Configuration or Engineering
mode requires a password. This password is always "stx" and is not possible to
change.
The password is not case sensitive. The system will return to Operation mode
after 3 minutes of user inactivity.
Access to Engineering or Configuration mode can also be gained by key commands
directly from the display.
• press Ctrl+E to enter Configuration mode
• press Ctrl+A to enter Engineering mode.
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This opens the password dialogue directly.
Restart

From the Restart menu item you can stop and immediately start:
• the NAV Engine
• the sensor unit
• the GNSS receivers
When restarting the NAV Engine or the sensor unit, the system will stop all
processing, calculation and output from the system for about 2 minutes. When
restarting the GNSS receivers both GNSS receivers will be restarted.

Stop
From the Stop menu item you can stop:
• the NAV Engine
• the Operator SW.
Stopping NAV Engine will stop data processing. Stopping the Operator SW will
close the Seapath application.
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7 Maintenance

7.1 Recalibration of the MRU
For Seapath installations with product software version 1.02.01 or later installed,
recalibration of the 5th generation MRU units are no longer required. This since the
Seapath software estimates the bias in the accelerometers and therefore recalibration is
no longer required.

The estimated accelerometers biases values are shown in the Data Viewer under the Tools
menu. The unit [µg] is used for the estimated accelerometer biases and and is equal
to 1e-5 m/s2. A horizontal accelerometer bias of 200µg (200 micro-g) will lead to an
angle offset of 0.01° if the bias is not corrected for. Over time the X-axis accelerometer
measures the static (mean) pitch angle and the Y-axis accelerometer measures the static
(mean) roll angle. It is the estimated accelerometer biases in the X and the Y that are
of interest and values are shown in the figure below. In the X axis the accelerometer
bias has been corrected with 28.374µg since the unit was calibrated. This correspond
to 0.00142° pitch angle offset if the unit is disconnected from the Seapath or the pitch
measurements are output from the MRU junction box. It will be similar for the Y-axis
accelerometer bias and the static roll angle.

7.2 Updating the sensor unit software
We recommend that you keep your product updated with the latest software version.
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Prerequisites
The default IP address for the sensor unit is: 192.168.1.10.
Note

The below procedure assume that the Seapath unit operate on
processing software version 2.01.00 or newer.

Procedure
1 Open a browser and type: http://<the default sensor unit IP

address> in the address bar.
2 Type the default login credentials:

• User name: scompact
• Password: 1234
The user name is case sensitive.

3 Enter the Configuration management and select Update SW.
4 Select the provided update package zip file.
5 Select Upload and wait up to 10 seconds for the file to be transferred.

6 Select Install.
The unit will then start to unpack the update package. The update process can
take some minutes.

Result
If the update was successful, the sensor unit will restart and the installation results will
show Installation successful together with a detailed report.
Should the update be unsuccessful, try again and contact Kongsberg Discovery AS
customer support.

7.3 Checking the product version
For software update or contact with customer support it is useful to know the product
version of the system.

Procedure
1 Select the System menu →About
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Observe the product version.
2 Select Details for more information about the unit.
3 Select Close to exit the dialog box.

7.4 Repairs and parts replacement

7.4.1 Repairing the sensor unit
The sensor unit is not designed for customer maintenance. All repairs and modifications
of the unit, except:
• installation of new software versions

should be carried out by qualified personnel. A failed unit should be shipped back to
Kongsberg Discovery AS or other agreed service point for repair.

7.4.2 Installing a spare sensor unit
If a spare unit is rented while your unit is in for repair, it is delivered with the latest
version of the product software.

Procedure
1 Disconnect the spider cable from the sensor unit.
2 Unscrew the four screws which hold the sensor unit to the mounting bracket.
3 Remove the sensor unit from the mounting bracket.
4 Place a new sensor unit in the mounting bracket.
5 Refasten the four screws which hold the sensor unit to the mounting bracket.
6 Reconnect the spider cable.

7.4.3 Repairing the MRU subsea bottle
The MRU subsea bottle holds the motion sensor unit (MRU). All repairs and
modifications of the subsea bottle and the motion sensor unit, except for installation of
new software versions and user configuration, have to be carried out by Kongsberg
Discovery AS.

Caution

Opening the sensor unit housing will result in permanent damage and the
user should under no circumstances make any attempt to do so.

A failed subsea bottle should be shipped back to Kongsberg Discovery AS or other
agreed service point for repair.
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7.4.4 Installing a spare MRU subsea bottle
You may want to install a spare MRU subsea bottle, for example if your bottle is in for
recalibration or pressure testing.

Procedure
1 Disconnect the MRU cable from the subsea bottle.
2 Unscrew the M6 screws which hold the subsea bottle to the mounting structure.
3 Remove the MRU subsea bottle and replace it with a new one.
4 Refasten the M6 screws which hold the subsea bottle to the mounting structure.
5 Reconnect the MRU cable to connector A on the connector lid.

7.5 Troubleshooting
Should you experience some problems with the product, try to use the troubleshooting
procedures to fix the problem. If you have followed the procedures for troubleshooting
and the problem is still not solved, contact Kongsberg Discovery AS support for
assistance.

Related topics
• Support information on page 13

7.5.1 System status
The error conditions in the system are usually observed by looking at the system status
field in the Top bar. The quality status information output on serial lines or Ethernet is
the same as data quality status indicated in the Top bar.

7.5.2 No power
If the Top bar shows No connection this can be due to the fact that the sensor unit
does not receive any power.

Procedure
1 Check the power connection to the unit.
2 Check that the PC with the operator software is configured to the same subnet as

the sensor unit.

7.5.3 External output problems
During operation situations may occur where the external equipment receives not data
from the sensor unit.
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Procedure
1 Check the serial lines, net cables and cable connectors for mechanical damage.
2 Check that the connectors are connected to the correct output ports on the external

equipment.
3 If the cable connectors are OK, check that the external output configuration of the

sensor unit is set up correctly.
This is described in the Installation manual.

7.5.4 All data quality status indicators are grey
During normal operation it takes a minute from the sensor unit is powered on until the
four data quality status indicators in the Top bar turn red. If all the indicators are still
grey after three minutes from power on, do as follows:

Procedure
1 Check the power connection to the sensor unit.

See power specification in the Installation manual.
2 Check that the PC with the operator software is configured to the same subnet as

the sensor unit.
If the indicator lights are still not turning red, contact your nearest Kongsberg Discovery
AS office.

7.5.5 All data quality indicators are red
During normal operation it can take up to 30 minutes from the sensor unit is powered
on until full accuracy on all data is obtained and the data quality indicators change
colour from red. If all the indicator lights are still red after 30 minutes from power
on, do as follows:

Procedure
1 Check if the MRU cable is properly connected to the sensor unit.
2 If not, switch off the power and connect the cables properly and power on the unit

again.
3 Check that the installation location of the sensor unit complies with the instructions

given in the Installation manual.

7.5.6 Pos/Vel indicator is red
The Pos/Vel data quality indicator in the Top bar is red. This may occur if the sensor unit
does not receive data from any of the GNSS receivers.

Procedure
1 Check that the sensor unit is not damaged.
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If the sensor unit is damaged, it has to be shipped back to Kongsberg Discovery
AS for repair.

2 Check that the installation location of the sensor unit complies with the instructions
given in the Installation manual.

7.5.7 Pos/Vel indicator is yellow
The Pos/Vel data quality indicator in the Top bar is yellow. This may occur if the system
experiences a reduced position/velocity function.

Procedure
1 No differential corrections are input on the GNSS serial cable of the sensor unit. If

differential corrections are input to the sensor unit, check that the link is properly
set up in the DgnssLink, part of the Input/Output subfolder in the NavEngine
configuration.

2 The vessel can be out of range to a radio reference station and the differential
corrections are therefore missing. If the reference station is too far away or it is in
the shadow of geographical obstructions or other equipment on board, reception
may be unreliable or missing. The location of the reference stations connected to
Seapath is shown in the DGNSS Monitor under the Tools menu.

3 The antenna or the MRU offset setup can be incorrect. Check the setup of the lever
arms from NRP to antenna #1 and to the MRU once again. Check particularly that
the sign for each of the vector components are correct by entering the Geometry
subfolder under Sensor→ GNSS →MRU in the NavEngine configuration.

7.5.8 Heave and Roll/Pitch indicators are red
The Heave and Roll/Pitch data quality indicators in the Top bar are red. This may occur if
the sensor unit does not receive any data from the motion reference unit (MRU).

Procedure
1 Check that data is coming in to the MRU connector on the sensor unit by selecting

the Tools menu →Port Monitor and selecting MRU.
2 Check that the MRU cable is properly connected to the subsea bottle.
3 If the above items are OK, see the section on troubleshooting the motion reference

unit (MRU).

Related topics
• No data from the motion reference unit (MRU) on page 58

7.5.9 Heave and Roll/Pitch indicators are yellow
When the Heave and/or Roll/Pitch data indicators in the Top bar are yellow, this indicates
that there are some problems with the motion reference unit (MRU). The MRU may for
some reason be unstable. See the section on troubleshooting of the motion reference
unit (MRU).
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Related topics
• Unstable data from the motion reference unit (MRU) on page 58

7.5.10 Heading indicator is red
When the Heading data indicator in the Top bar is red, it can indicate a problem with
the heading calculation.

Procedure
1 Perform a new calibration of the antenna baseline.
2 The sensor unit receives no data from GNSS receiver no. 1 or 2. That can be

verified by checking whether data appear on the Port Monitor in the Tools menu and
by selecting GNSSA1 for GNSS antenna number 1 and GNSSB1 for antenna no.
2. If no data are received, perform a receiver reset by selecting the System menu
→Restart →GNSS receiver.

7.5.11 Heading indicator is yellow
When the Heading data indicator in the Top bar is yellow, the system may experience a
reduced heading performance.

Procedure
1 It may be due to a problem the motion reference unit (MRU). Check that by

troubleshooting the MRU.
2 If the MRU is functioning OK, check that the antenna baseline setup parameters in

the NAV Engine Configuration, Sensors →GNSS →Geometry, are properly configured,
and if needed, perform a new calibration of the antenna baseline.

3 The sensor unit receives no data from GNSS receiver no. 1 or 2. That can be
verified by checking whether data appear on the Port Monitor in the Tools menu and
by selecting GNSSA1 for GNSS antenna number 1 and GNSSB1 for antenna no.
2. If no data are received, perform a receiver reset by selecting the System menu
→Restart →GNSS receiver.

If it is still not working after checking all of the above items, then the GNSS receiver
board within the sensor unit is most likely damaged and the sensor unit has to be shipped
to Kongsberg Discovery AS for repair.

Related topics
• Unstable data from the motion reference unit (MRU) on page 58

7.5.12 Heave indicator is yellow
If the Heave data indicator in the Top bar is yellow, this can be due to the fact that the
system, to which the sensor unit is connected, is experiencing reduced performance in
heave or depth errors in the centre beam of an echo sounder. If reduced performance in
heave or depth errors occur in an echo sounder, check the following.
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• There are oscillations in heave or in the depth of the centre beams. Check that the
correct Heave filter mode and Heave period are selected in the sub-folder Sensors
→MRU →Heave config in the NAV Engine Configuration.

7.5.13 Roll/Pitch indicator is yellow
If the Roll/Pitch data indicator in the Top bar is yellow, the system experiences a reduced
roll or pitch performance.

Procedure

7.5.14 No data from the motion reference unit (MRU)
If the Heave and/or Roll/Pitch data indicators in the Top bar are red, a possible cause can
be that the sensor unit does not receive any data from the motion reference unit (MRU).

The tools for troubleshooting the MRU are the Data Viewer and the Port Monitor.

Procedure
1 Check that data is coming in to the MRU connector on the sensor unit by selecting

the Tools menu →Port Monitor and selecting MRU.
2 Check that the cable from the sensor unit is properly connected to the MRU subsea

bottle.

7.5.15 Unstable data from the motion reference unit (MRU)
If the Heave and/or Roll/Pitch data indicators in the Top bar are yellow, a possible cause
can be that the data received from the motion reference unit (MRU) are unstable.

The tools for troubleshooting the MRU are the Data Viewer and the Port Monitor.

Procedure
1 Select Tools menu→Data Viewer →PPS and time to check if the Status parameter in

the PPS information group indicates Sync. If this is the case, the sensor unit and the
MRU are probably synchronized with GPS.

2 In order to be sure that the sensor unit gets MRU data on time, select Tools menu
→Data Viewer →Time delay. The time delay for the Raw MRU parameter should be
0.020 seconds or less.
If the time delay is greater than 0.020, the MRU cable carrying the PPS signal from
the sensor unit is not properly connected.

7.5.16 Echo sounder depth error
Sometimes the system may experience depth errors in the outer beams on a multi-beam
echo sounder. Check the following if a depth error occurs.
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Procedure
1 The oscillations in the depth of the outer beams are correlated with the pitch angle of

the vessel. Check the mounting angle around the z-axis. The sensor unit x-axis has
to be parallel with the ship's longitudinal axis as long as the echo sounder transducer
head is aligned with the ship axes.

2 The oscillations in the depth of the outer beams are correlated with the roll angle
of the vessel. Check that the distance vector from the ship Origin to the MRU is
input correctly both when it comes to the length and the sign. Check also that the
vector from Origin to GNSS antenna no. 1 is input correctly both when it comes
to the length and sign. Check specially the sign in the vertical direction, which
always shall have a negative sign. Look at the background vessel in the NAV Engine
Configuration (part of the operator software) to check whether the arms and vector
signs look correct.

3 There is incorrect synchronisation of the Seapath and the multi-beam data (timing
error). Check that the measurements from the two data sources are handled correctly
and that a timing error has not occurred. Post-processing of the Seapath and the
multi-beam data can be used to analyse whether incorrect synchronisation is the
reason for the depth errors.

7.5.17 Unstable heading calculations for high dynamic
vessels
The GNSS attitude processing setting allows you to improve heading calculations for
vessels which experience a roll of more than 15 degrees.

Context
If the vessel has a roll and pitch above 15 degrees, the system will have problems with
heading calculations. The maximum values to be used for attitude processing can be
changed if the vessel has an unusual characteristic.
With the Glonass option you can decide whether the GLONASS satellites shall be used
in the heading solution or not.
The default setting is RTK and Float

Procedure
1 Select the System menu, →NAVEngine →Standard to open theNAV Engine

Configuration dialog box.
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2 Select the Sensors node →GNSS →Attitude Processing.
3 Type the wanted degrees for max pitch and roll angles.
4 Type the wanted degrees for average pitch and roll angles.
5 In the Glonass option drop-down list, select if you want GLONASS satellites to be

used in the heading solution.
• Off: GLONASS satellites are not used.
• RTK and Float: This is the default value.
• Float only: Should only be used by experts after advice from Kongsberg

Discovery AS support.
6 Select Apply to store the settings.

7.5.18 Using GLONASS in RTK solution
The RTK (Realt Time Kinematic) parameters allow you to enhance the precision of
position data which are derived from satellite-based positioning systems, such as GPS
and GLONASS.

Context

These settings can be changed to optimise the performance in RTK mode.

Search mode

The default search mode is Normal. Safe mode is recommended used under difficult
conditions with much multipath or ionospheric activity and for long baselines. Fastmode
is recommended used when a fast RTK solution is required.

Note

In Fast mode the probability for an incorrect solution from the system will increase.

Glonass option

The default setting is RTK and Float. The RTK and Float selection is recommended
used under conditions where the RTK correction source is known (own local reference
station). The Float only selection is used when the system has problems with getting an
RTK solution. The Off selection is used when the RTK corrections include only dual
frequency GPS corrections.
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Procedure
1 Select the System menu, →NAVEngine →Standard to open theNAV Engine

Configuration dialog box.
2 Select the Sensors node →DGNSS →RTK.
3 In the Search mode drop-down list, select the wanted search mode if you do not

want the default mode Normal.
4 In the Glonass option drop-down list, select the wanted parameter if you do not

want the default setting RTK and Float.
5 Select Apply to store the settings.

7.5.19 Setting up distribution channel parameters for the
sensor unit
Data pool is the distribution channel for data from the NAV Engine software running of
the sensor unit to the operator software (HMI).
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Procedure
1 Select the System menu, →NAVEngine →Standard to open theNAV Engine

Configuration dialog box.
2 Select the Communication interface node →DataPool.
3 Type an identifying name for the sensor unit (Processing unit name).
4 Type the UDP address to which the NAV Engine shall send data.
5 Type the UDP port to which the NAV Engine shall send data.

Note

The UDP address and UDP port entered here have to match the Address and Port
entered in the Data Source tab in the Operator software configuration to ensure
communication between NAV Engine and the Operator software.

6 Select Apply to store the settings.
7 Change the HMI settings to reflect the new data pool parameters in the System menu

→Operator SW →Data source.
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8 Concept description

8.1 System architecture
The product is a two-module solution with a Sensor Unit and an external PC with the
operator software connected via Ethernet. The Sensor Unit runs the processing software
which handles all critical computations independent of the user interface on the external
PC to ensure continuous and reliable operation.

The product is operated through the operator software installed on the external PC.
This software is used for performance monitoring and configuration of the system. For
performance monitoring the software includes a number of views that can be adjusted
to different operations.

Figure 4 System sketch

M340-53/6.0 63



Seapath 130 series

8.2 Main data flow
The illustration shows the main data flow to and from the Sensor Unit.

Figure 5 Sensor Unit with the NavEngine software

The NavEngine software runs on the Sensor Unit. This software combines the GNSS
signal and the inertial measurements to determine accurate position, heading, attitude and
heave signal. The NavEngine software utilises Kongsberg Discovery AS advanced true
multi-reference algorithms for real-time parallel processing of all available correction
signals including:
• SBAS (WAAS, EGNOS, MSAS, QZSS)
• IALA
• Standard RTCM corrections (DGNSS)
• Fugro SeaSTAR High Precision services (XP, G2, G4, G4+)
• VERIPOS Ultra/Ultra2 correction services
• C-NavC1 and C-NavC2 correction services
• RTK corrections of RTCM version 3 messages or type 18 and 19

There is no practical limitation to the number of correction signals/reference stations
handled by the NavEngine.
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8.3 Real-time heave computation
Heave is the vertical position or height relative to a zero mean level and positive
downwards. The vertical acceleration is high pass filtered and integrated twice over time
to heave position. Heave velocity is computed with one integration over time of filtered
vertical acceleration. The heave filter removes static and slowly varying errors.

The user must tune this filter according to user requirements. The heave filter parameters
should be selected according to the expected average wave period T0 for the vessel.
The expected average wave period T0 can be selected in the range 1 to 25 seconds.
If a too long period is selected, the velocity and position outputs will have a slowly
varying error. If a too short period is chosen, the estimated heave will have a phase error
for long period motions.

A low damping factor ε reduces the short-term error for long period motions close to
the selected average period T0, since the phase error is reduced. However, ringing in
the output at T0 may cause some problems. The damping factor ε is recommended
set fixed to 0.7.

In the software two different types of filter structures are implemented. The filter
mode "General purpose" is implemented to achieve optimal amplitude performance,
whereas the "Hydrographic survey" mode provides optimal phase performance. For the
"Automatic" filter mode the hydrographic survey filter structure is used. This algorithm
estimates the sea conditions by computing the dominating period of the waves seen
from ship or vehicle and automatically sets the average heave period T0 in real time
during operations.

In the "GNSS aided" mode the heave and height measurements are determined by
blending vertical acceleration and RTK height measurements in a Kalman filter.

8.3.1 Selection of heave filter mode
The following selections are available in the configuration in order to achieve the optimal
heave performance:
• Heave filter mode. Selection between different filter structures.
• Period. The average heave period for the vessel, T0.

The heave filter average period should be chosen in order to obtain the best possible
correspondence between the estimated heave motion and the real heave motion. The
average period can be set to a constant value or the automatic adaptive filter may be
selected in case of varying sea states.

The following should be considered when selecting the different heave filter modes:

Heave filter mode:
• General purpose. Is selected when optimal heave amplitude is to be measured and

the heave phase is of no importance. This mode is typically selected when the system
is to be used for measuring the heave height and period on oceanographic buoys.
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• Hydrographic survey. To be selected when the heave phase and amplitude have to
be output correctly in real time and the heave period is known. This mode is typically
selected when the heave output signal from the system is to be used for heave
compensation of echo sounders, hydro acoustic positioning systems and offshore
crane systems.

• Automatic. To be selected when the amplitude and phase have to be output correctly
in time and the wave period is not known. The automatic filter estimates the heave
period adaptively and can be used instead of Hydrographic survey filter when the
heave period is unknown or varying. This is the recommended filter mode for
real-time heave at sea.

• GNSS aided. To be selected when RTK DGNSS corrections are available or the
GNSS velocity measurements are accurate. In this mode the heave and height
measurements are determined by blending vertical acceleration and GNSS height
measurements in a Kalman filter. This combination makes it possible to measure
wave slopes and the tide in real time with high precision ideal for hydrographic work.
The height measurements are provided with centimetre accuracy and independent
of wave frequency. If RTK is not available the algorithm will use the GNSS
velocity measurements for aiding the heave. If GNSS velocities are not available,
the Automatic algorithm is used.

Period:
• An expected average heave period has to be set to the heave filter unless the automatic

or the integrated mode is chosen.
• The settling time for the heave measurements from power-on will be about 10 times

the selected period, T0.

The selection of heave filter period is a trade-off between low heave error over a wide
range of heave periods and the settling time after an occurrence introducing a step
response in the heave filter.

The figure Relative heave error as function of wave period on page 67 illustrates the
relative heave residual in percentage of amplitude for the "Hydrographic survey" filter
with damping 0.7 and various average heave periods of 5, 10, 15 and 20 seconds.

The figure Heave step response with corresponding settling time on page 67 illustrates
the heave step response with corresponding settling time for the "Hydrographic survey"
filter with damping 0.7 and various average heave periods of 5, 10, 15 and 20 seconds.
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Figure 6 Relative heave error as function of wave period

Figure 7 Heave step response with corresponding settling time
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8.4 Delayed heave output
The new developed PFreeHeave® algorithm uses past measurements to output a correct
and phase-free heave from Seapath. PFreeHeave® has an advantage in long swell
conditions and for applications that can utilise a heave signal that is delayed some
minutes, typical seabed mapping applications. The PFreeHeave® signal can be output on
serial line or Ethernet (UDP/IP) together with the real-time heave signal.

To take advantage of this new functionality, the Seapath user has to post-process the
echo sounder recordings together with the motion sensor recordings. The application
of delayed heave has to be performed in post-processing software delivered from QPS,
CARIS, EIVA, HYPACK, Kongsberg Discovery and others. These software packages
are able to read the PFreeHeave® format. See the Installation Manual for details on
the PFreeHeave® format.

8.5 High speed data in real-time
By the integration of motion data with GNSS positions in the Kalman filter, a 100 Hz
update rate of heading, roll, pitch and position is achieved. All Seapath data are output in
real-time, including the position data, due to internal processing by use of accelerometer
measurements between each GNSS position. This eliminates delays due to processing.
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how to, repair sensor unit, 53
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pitch, 39
Port Monitor, 48
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position/velocity, reduced, 56
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product version, how to
check, 52
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reduced roll/pitch
performance, 58
reduced, position/velocity, 56
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